PDA

Volledige versie bekijken : CoD:MW2 Blackscreen



Skipze
15 januari 2010, 00:02
Hi,

Mijn probleem is nogal ingewikkeld en ik vind nergens een oplossing, dus ik dacht misschien hier maar eens vragen.

Als ik MW2:Multiplayer start komt er gewoon een zwart scherm, ik kan mijn muis niet zien en kan niet alt+tab doen. Als ik ctrl+alt+del doe an ik wel naar taakbeheer gaan, daar kan ik echter niet het proces beeindigen, als ik de taak stopzet blijft het spel runnen, maar is er enkel een zwart vierkant kadertje linksbove op m'n scherm.

Ik heb al 2 keer compleet geherinstalleerd, 1 keer een mogelijk oplossing gevolgd waarmee ik eerst back-up maak, dan alles verwijder en dan restore van de backup, en geprobeerd een bepaald bestand te verwijderen dat zogezegd zorgt voor mijn probleem.

Niets, maar dan ook niets van deze mogelijkheden werkt!

Ik vind het héééééél irritant want ik speel het spel dagelijks, en ik heb niets van problemen gehad hiervoor...

Mvg

Yvezzke
15 januari 2010, 14:41
Specs van de pc in spé aub.

Dit komt rechtstreeks van het steam-forum:

I fixed my 30 second freeze at the start by doing a few things, honestly i'm not sure how i fixed it, or which one of my actions led to the remedy.

-Turned off UPNP in my router. (Manual Port Forward)
-Deleted some mp_playlist file in my game files.
-set my game to run in compatibility mode of XP SP3
-set my game to Disable Visual Theme's when starting up.
-check-marked "Run As Administrator" , though that has no effect since i turned off UAC.

Now there is absolutely NO FREEZING when i start my game.

->Windows 7 x64


you should also try out compatibility mode (xp sp3) , and run as admin for steam.exe as well
------------------------------------------------------------------------------------------------

Dit komt van CODBoards(gevonne via google)

Hey guys! I tried changing the language on game properties on Steam, then the game went on update, but it was too slow so I stopped it and then reinstalled the game from DVD (first I deleted the game folder in C:\Program files\steam\steamapps\commo\call of duty modern warfare 2)... then I launched MP and... magically... IT WORKED! I tried to close and launch it again and... IT WORKED FINE!!! I hope it won't crash again...

P.S.: I unistalled Spyware Doctor, don't know if it was the cause of the problem...
------------------------------------------------------------------------------------------------

Dit komt van het IW forum zelf:

Problem: Call of Duty 4 Modern Warfare 2 Crashing / Freezing ingame
Solution #1 : just disable Steam community in-game.

Solution #2 : just go in Steam\SteamApps\common\call of duty modern warfare 2\Redist\DirectX and run DXSETUP.

Solution #3 :

# Set your desktop to a resolution of 1024×768, 32 bit True Color.
For Windows XP
1) Right-click on your desktop and select Properties.
2) Click the Settings tab.
3) Set your screen area to 1024×768.
4) Set the colors to Highest (32 bit).
5) Click Apply and OK.
For Windows Vista\Windows 7
1) Right-click on your desktop and select Personalize.
2) Click on Display Settings
3) Set the resolution slider to 1024X768
4) Set the colors to Highest (32 bit).
5) Click Apply and OK.
# All background applications should be shut down prior to running the game.
1) Go to the Start bar and select Run. (If you are on Vista or Windows 7, hit the Windows key and the R key at the same time)
2) In the Run window, type in msconfig and hit enter.
3) Once the utility comes up, go to the Startup tab and hit the Disable All button.
4) Next go to the Services tab and check the “Hide All Microsoft Services” checkbox and then hit the Disable All button.
5) Hit the OK button and close the utility, and restart your computer when prompted to.
# Turn your sound acceleration down for Windows XP
1) Click the Start button > Settings > Control Panel.
2) Double-click the Sounds and Audio Devices icon.
3) Click the Volume tab.
4) Under Speaker settings, click the Advanced button.
5) Click the Performance tab.
6) Reduce the Hardware acceleration to Basic, the 2nd notch from the left.
7) Click Apply and then OK 2 times. Run the game now. Don’t forget to turn the acceleration back up to restore the high-end features for your sound card when using other applications.
------------------------------------------------------------------------------------------------



Laat iets weten of het helpt of niet.

Skipze
15 januari 2010, 16:26
Fucking nice, Solution 3 werkte! Echt merci Semtex, big thanks to you!

Nu is mijn scherm wel in lelijkste resolutie ooit, mag ik da terugzette of? xD

Thanks man, echt

edit: resolutie teruggezet en werkt nog steeds, echt man dikke merci to you :D

Yvezzke
15 januari 2010, 17:16
Geen probleem, goed dat het weer werkt.