Weergegeven resultaten: 1 t/m 2 van 2
  1. #1
    Member
    Lid sinds
    7/10/06
    Locatie
    Antwerp
    Berichten
    910
    iTrader
    37 (100%)

    Exclamation document.getElementById(...) werkt niet

    Hey iedereen

    Voor een schoolproject moeten wij XAML files genereren en deze vervolgens via Javascript laten animeren.

    Het eerste deel van mijn opdracht werkt feilloos, maar wanneer ik deze in javascript wil implementeren loopt het fout.

    Ik heb nl. een vrij basic htm pagina:
    HTML-code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
        <head>
            <title>Information Gain Page</title>
            <link href="Css/xmltech.css" rel="stylesheet" type="text/css" />
            <script src="Javascript/Silverlight.js" type="text/javascript"></script>
            <script src="Javascript/InformationGain.js" type="text/javascript"></script>
        </head>
        <body>
            <object 
            id="infoPage" 
            width="1000" 
            height="1000" 
            type="application/x-silverlight">			    
    	      <param name="source" value="Xaml/InformationGain.xaml"/>          
            </object>		   		    
        </body>
    </html>

    maar als ik het volgende probeer, krijg ik gewoon niets van meldingen:

    HTML-code:
    var defaultPage = null;
    
    function onLoaded() {
        defaultPage = document.getElementById('infoPage');
        //alert('In onloaded van InformationGain.xaml.');
        alert(defaultPage);
    }
    Het weergeven van de XAML verloopt allemaal correct, de onloaded ook (alert van in onloaded werkt) maar toch wilt hij de defaultPage niet opvullen en ik heb geen flauw idee waarom.. Vorige oefeningen gechecked, volgorde nageleefd en nog steeds lukt het niet.

    Als iemand me uit deze nood kan helpen, ge zijt vree hard bedankt!
    It are the small things that make us more human than we wish for...

  2. #2
    Member
    Lid sinds
    7/10/06
    Locatie
    Antwerp
    Berichten
    910
    iTrader
    37 (100%)
    Oke, nvm, kheb de fout gevonden.

    In de XML stond er een tipfout.

    Ik had Loaded="onLoadef" geschreven.. dan werkt da natuurlijk ni.
    It are the small things that make us more human than we wish for...

Discussie informatie

Users Browsing this Thread

Op dit moment bekijken 1 gebruikers deze discussie. (0 leden en 1 gasten)

Regels voor berichten

  • Je mag geen nieuwe discussies starten
  • Je mag niet reageren op berichten
  • Je mag geen bijlagen versturen
  • Je mag niet je berichten bewerken
  •